Resolved
✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.
Monitoring
AWS infrastructure in the us-west-2 region has recovered, and qTest, Testim, and Waldo are now available again.
We are continuing to monitor all services closely to ensure stability. If you continue to experience any issues, please contact our support team.
Investigating
qTest is fully unavailable in the US-WEST-2 region (Sev1), affecting all customers routed there. Root cause is not yet confirmed — investigation is in early stages.