Resolved
✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.
Monitoring
The root cause has been addressed and corrective changes have been implemented. The qTest–Jira integration is now stable, with the team continuing close monitoring.
Investigating
We are currently investigating the delay between qTest and Jira synchronization in eu-west-1 region. The team is working to identify the root cause and will provide an update as soon as more information is available.