Resolved
✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.
Monitoring
The qTest application in the US East (N. Virginia) region (us-east-1) has been restored. A fix has been implemented, and the service is currently operating normally.
Our engineering team is closely monitoring the system to ensure continued stability. We will provide further updates if necessary.
Investigating
The qTest application in the US East (N. Virginia) region (us-east-1) is currently experiencing a complete outage.
Our engineering team is actively investigating the issue and working to restore full service as quickly as possible. Updates will be provided as soon as new information is available.