Resolved
✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.
Monitoring
The issue affecting qTest Manager in the following regions has been mitigated:
EU-West-1
US-East-1
Service functionality has been restored, and our teams are actively monitoring the situation to ensure stability. We will continue to observe the system closely and provide further updates if needed.
Investigating
We are investigating an issue affecting qTest Manager in the following regions:
EU-West-1
US-East-1
After applying a navigation tree filter in Test Design, the Test Design page may appear blank. In this state, standard actions such as creating Modules, Test Cases, accessing the Recycle Bin, or using filters may be unavailable.
Our engineering team is actively working on identifying the root cause and a resolution. Further updates will be shared as they become available.