Tosca service degradation in Canada
Resolved·Partial outage

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Mon, Jan 5, 2026, 09:29 AM
(1 day ago)
·
Affected components
Updates

Resolved

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Mon, Jan 5, 2026, 09:29 AM

Identified

🛠️ We have identified the root cause of the issue and are working on a fix. We’ll continue to share updates as we make progress.

Fri, Jan 2, 2026, 04:00 AM(3 days earlier)