qTest Sessions customers may experience slowness
Resolved·Degraded performance

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Wed, Sep 24, 2025, 06:17 PM
(6 days ago)
·
Affected components
Updates

Resolved

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Wed, Sep 24, 2025, 06:17 PM

Identified

🛠️ We have identified the root cause of the issue and are working on a fix. We’ll continue to share updates as we make progress.

Wed, Sep 24, 2025, 04:45 PM(1 hour earlier)

Investigating

:mag: We are currently investigating qTest Session slowness. Customers may experience the slowness. We will keep you posted.

Wed, Sep 24, 2025, 03:56 PM(49 minutes earlier)

Investigating

🔍 We are currently investigating slowness of the qTest Sessions. Our team is looking into the cause and will provide an update as soon as we have more information.

Wed, Sep 24, 2025, 03:19 PM(36 minutes earlier)