Issues with delete of test runs
Resolved·Degraded performance

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Tue, Sep 23, 2025, 05:04 PM
(1 week ago)
·
Affected components
Updates

Resolved

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Tue, Sep 23, 2025, 05:04 PM

Identified

🛠️ We have identified the root cause and successfully applied the fix in AP-SOUTHEAST-2. Work is ongoing to apply the fix across the remaining regions. We will continue to share updates as progress is made.

Tue, Sep 23, 2025, 04:49 PM(15 minutes earlier)

Investigating

🔍 We are currently investigating issues with deleting the test runs in the qTest Manager application. We will keep you posted.

Tue, Sep 23, 2025, 04:00 PM(48 minutes earlier)