Resolved
✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.
Monitoring
👀 A fix has been implemented and we are currently monitoring the system to ensure everything is working as expected. Overall slowness is decreasing and latency is returning to normal levels, though some customers may still experience intermittent slowness.
Identified
🛠️ We have identified the root cause of the issue and are working on a fix. We’ll continue to share updates as we make progress.