Decreased performance of the qTest
Resolved·Degraded performance

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Fri, Sep 19, 2025, 07:11 AM
(1 week ago)
·
Affected components
Updates

Resolved

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Fri, Sep 19, 2025, 07:11 AM

Monitoring

👀 A fix has been applied and the system is being closely monitored. Background processes are still completing, so you may continue to experience minor delays in processing.

Thu, Sep 18, 2025, 09:30 PM(9 hours earlier)

Investigating

🔍 We are currently investigating reports of an issue. Our team is looking into the cause and will provide an update as soon as we have more information.

Thu, Sep 18, 2025, 07:45 PM(1 hour earlier)