qTest Service Degradation
Resolved·Degraded performance

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Tue, Sep 16, 2025, 09:07 AM
(2 weeks ago)
·
Affected components
Updates

Resolved

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Tue, Sep 16, 2025, 09:07 AM

Identified

🛠️ We have identified the root cause of the issue and are working on a fix. We’ll continue to share updates as we make progress.

Tue, Sep 16, 2025, 08:20 AM(47 minutes earlier)