Scheduled Maintenance: Testim – Sunday, August 31, 2025, 5:30 AM to 2:30 PM UTC
Complete·Under maintenance

Maintenance has completed

Sun, Aug 31, 2025, 01:35 PM
(1 month ago)
·
Affected components
US-EAST-1 | Grid
Updates

Complete

Maintenance has completed

Sun, Aug 31, 2025, 01:35 PM

In progress

We will be conducting scheduled maintenance on Sunday, August 31, 2025, from 5:30 AM to 2:30 PM UTC.

This maintenance is part of our ongoing efforts to enhance security and ensure the continued reliability, performance, and protection of our infrastructure. The maintenance window is expected to last up to 9 hours, during which brief service disruptions may occur.

Sun, Aug 31, 2025, 09:25 AM(4 hours earlier)

In progress

We will be conducting scheduled maintenance on Sunday, August 31, 2025, from 5:30 AM to 11:30 AM UTC.

This maintenance is part of our ongoing efforts to enhance security and ensure the continued reliability, performance, and protection of our infrastructure. The maintenance window is expected to last up to 6 hours (extended by 3 hours), during which brief service disruptions may occur.

Sun, Aug 31, 2025, 08:05 AM(1 hour earlier)

In progress

Maintenance has started

Sun, Aug 31, 2025, 05:30 AM(2 hours earlier)

Scheduled

We will be conducting scheduled maintenance on Sunday, August 31, 2025, from 5:30 AM to 8:30 AM UTC.

This maintenance is part of our ongoing efforts to enhance security and ensure the continued reliability, performance, and protection of our infrastructure. The maintenance window is expected to last up to 3 hours, during which brief service disruptions may occur.


Thank you for your understanding and continued support.

Sun, Aug 24, 2025, 02:59 PM(6 days earlier)