Issues with TDC
Resolved·Degraded performance

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Fri, Jul 11, 2025, 05:28 AM
(6 days ago)
·
Affected components
Updates

Resolved

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Fri, Jul 11, 2025, 05:28 AM

Identified

🛠️ We have identified the root cause of the issue and are working on a fix. We’ll continue to share updates as we make progress.

Thu, Jul 10, 2025, 04:03 PM(13 hours earlier)

Investigating

🔍 We are currently investigating reports of a TDC functionality issue. Our team is looking into the cause and will provide an update as soon as we have more information.

Thu, Jul 10, 2025, 03:48 PM(15 minutes earlier)