tricentis

Report a problemSubscribe to updates
Powered by
Privacy policy

ยท

Terms of service
Testim: Elevated test execution failures
MonitoringยทPartial outage

๐Ÿ‘€ A fix has been implemented and we are currently monitoring the system to ensure everything is working as expected.

Thu, Jun 25, 2026, 03:42โ€ฏPM
(3 hours ago)
ยท
Affected components
02:04โ€ฏPM
Now
Updates

Monitoring

๐Ÿ‘€ A fix has been implemented and we are currently monitoring the system to ensure everything is working as expected.

Thu, Jun 25, 2026, 03:42โ€ฏPM

Identified

๐Ÿ› ๏ธ We have identified the root cause of the elevated test execution failures and increased error rates in our US region. Our team has applied a fix and is monitoring the platform to confirm recovery.

We apologize for the disruption and appreciate your patience.

Thu, Jun 25, 2026, 03:20โ€ฏPM(22 minutes earlier)

Investigating

๐Ÿ” We are currently investigating reports of an issue. Our team is looking into the cause and will provide an update as soon as we have more information.

Thu, Jun 25, 2026, 02:04โ€ฏPM(1 hour earlier)