Resolved
✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.
Monitoring
We experienced a service disruption affecting qTest in the EU region for approximately 5 minutes. The issue was quickly identified and resolved, and service has been fully restored.
Our team is actively monitoring the environment to ensure continued stability. We apologize for any inconvenience this may have caused and appreciate your patience.