tricentis

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
qTest is unreachable in us-east-1 region
Resolved·Full outage

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Wed, Apr 29, 2026, 08:20 PM
(1 month ago)
·
Affected components
Apr 29, 2026, 06:35 PM
06:56 PM
Updates

Resolved

✅ The issue has been resolved. All systems are operating normally. Thank you for your patience.

Wed, Apr 29, 2026, 08:20 PM

Monitoring

We have implemented the fix, qTest is back online in us-east-1. Team is closely monitoring the situation.

Wed, Apr 29, 2026, 06:56 PM(1 hour earlier)

Investigating

We are currently investigating an outage affecting qTest in the us-east-1 region. The team is actively working to identify the root cause and will share an update as soon as more information becomes available.

Wed, Apr 29, 2026, 06:35 PM(20 minutes earlier)