Resolved
The issue has been resolved, customers are able to request the Trial versions.
Investigating
We are currently investigating reports of an issue during Trial creation in us-east-2. Our team is looking into the cause and will provide an update as soon as we have more information.