Resolved
The issue affecting qTest Trial creation in the EU region has been resolved.
Customers can now proceed with creating new trials. If needed, they may also recreate their trial or contact Customer Support for further assistance.
Monitoring
A fix has been implemented and we are currently monitoring the system to ensure everything is working as expected.
Identified
We have identified the root cause of the issue and are working on a fix. We’ll continue to share updates as we make progress.
Investigating
We are currently investigating reports of an issue with qTest Trial creation in EU region. Our team is looking into the cause and will provide an update as soon as we have more information.